Site Status Page

Site Status

Errors when attempting to pay for an order (buyers)
Incident Report for iOffer
Resolved
We've identified and resolved the network issue with our external credit card processor. Payments are now being processed as normal.
Posted about 1 year ago. Jun 09, 2016 - 04:11 UTC
Investigating
We're investigating an increase in errors/timeouts when attempting to pay for an order with a credit card. This is only affecting a small portion of transactions. Update(s) to follow.
Posted about 1 year ago. Jun 09, 2016 - 03:26 UTC