Site Status Page

Site Status

Outbound Emails
Incident Report for iOffer
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 08, 2016 - 17:32 UTC
Identified
We've identified and resolved an issue with emails not being delivered. If you were expecting an email you be receiving it in the near future. Thank you for your patience.
Posted about 1 year ago. Sep 06, 2016 - 18:49 UTC