Site Status Page

Site Status

Order message time-outs
Incident Report for iOffer
Resolved
Thanks for your patience!
Posted about 1 year ago. Nov 01, 2016 - 23:26 UTC
Investigating
We're looking into an issue causing messages to time-out on order summary pages. We'll keep you updated. In the interim, please use iOffer Email relay directly from your inbox: http://help.ioffer.com/hc/en-us/articles/201216440-What-is-iOffer-s-2-way-email-relay :)
Posted about 1 year ago. Nov 01, 2016 - 18:21 UTC